Most Valuable Professional


View Jan Karel Pieterse's profile on LinkedIn subscribe to rss feed
Subscribe in a reader

Audit !!!

Probeer onze RefTreeAnalyser
de beste Excel formule auditing tool.

Speed up your file

FastExcel
The best tool to optimise your Excel model!
Home > Nederlandse site > Artikelen > Excel Namen > Gebruik
This page in English

Bereiknamen in Excel

Hoe kunnen gedefinieerde namen worden gebruikt

Met de tabel van Afbeelding 3 (zie paragraaf 1) kan getoond worden wat er met namen mogelijk is. Wanneer de som van verkochte appels berekend moet worden, zou daarvoor normaal gesproken de formule =SOM(B2:B4) gebruikt worden. Na het definiëren van namen kan echter volstaan worden met =SOM(Appels). Het moge duidelijk zijn, dat deze laatste formule veel eenvoudiger te begrijpen is.


Afbeelding 5, formule met naam

Een interessant feit is verder, dat een naam altijd een matrix is (in de Excel beleving). Als een gelijk aantal cellen wordt geselecteerd als het aantal waarnaar de naam verwijst, dan kan dit worden getoond. Selecteer 3 cellen boven elkaar, tik in =Appels en sluit af met control-shift-enter. De waarden van de cellen waarnaar de naam verwijst worden getoond:


Afbeelding 5a: Een naam is een matrix

Er kunnen ook andere dingen met namen gedaan worden. Zo geeft deze formule de omzet aan appels in Europa (1000):

=Appels Europa

Door de twee namen te scheiden met een spatie wordt hier aangegeven dat het snijpunt van beide namen gebruikt moet worden. Dit snijpunt kan overigens meerdere rijen en kolommen beslaan.

In feite kunnen namen worden toegepast op alle plaatsen in Excel waar een cel of een bereik van cellen moet worden opgegeven.

Één speciaal voorbeeld is het valideren van data met de "lijst" optie (Zie afbeelding 6). Zonder in te gaan op deze krachtige functie in Excel wordt even getoond, dat het hiermee mogelijk wordt een lijst op te geven die zich niet op hetzelfde blad bevind als het celbereik waarvoor de validatie wordt ingesteld. Normaal gesproken is dit niet mogelijk:


Afbeelding 6:Data, valideren, lijst optie

Om nu toch een bereik van een ander werkblad te kunnen toepassen kan gebruik gemaakt worden van de naam die eerder aan dit bereik gegeven is: "Appels".

Vul deze formule in in het invoervak "Bron":

=Appels

De validatie zal nu wel worden geaccepteerd.